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1 Importer une image satellite et des données de

terrain depuis PVsyst

Dans ce chapitre, nous allons explorer une méthode efficace pour importer a la fois la
topographie du terrain et une image satellite en quelques étapes simples a l'aide de la
fonctionnalité V8, "Télécharger une image satellite et/ou des données de terrain".
Cette approche offre une amélioration significative par rapport a la méthode précédente
(décrite dans le chapitre suivant), car elle élimine la nécessité de sélectionner
manuellement des points sur la carte et de convertir les données au format CSV.

e Accéder al'outil de téléchargement

o Danslascene 3D de PVsyst, allez dans Fichier > Importer > Télécharger

une image satellite et/ou des données de terrain.

® Construction de la scéne d'ombrage

Fichier Créer Sélectionner Editer Transformer Voir Outils Aide

# Nouvelle scene Crl+N Yo Zy 4Z = L
e JES I Q@ (9D | Dm | S A
Lire une scéne Ctrl+0 i
Point de vue Zoom Rendu Modules Mesure Medification

Lire un batiment :

Lire des objets i Zenith Eona
=% |Importer > Impaorter une scéne 3D (305, DAE, PVC) ..4"'.
Y Exporter la scéne (SHD) Ctrl+S | wer Importer un fichier Helios3D (H2P)

Exporter les objets sélectionnés (SHO) rsu Importer des données tepographiques (CSV, TIF)

B Sauver cette vue de la scéne >| @ Importer une image de sol
= mprimer culp | @ Télécharger une image satelite de sol et/ou des données topographiques
*® Annuler Ctri+Q |

Fermer la scéne Crl+W :

Quest Sud

Taile case: 1.00 m Géographigue - Vue perspective + X: -6.98, Y:-15.68 m Surf. active : 0.00 mz

Figure 1: Télécharger une image et des données satellite

e Explorer la carte interactive

4 § M=
4 AT | -9
Qutils Référentiel
.ObJetsda\ascéne Outils
¥ Objets de la scéne
Mom L%
(5 Champs PV (0)
(@ Objets (0)
¥ Orientations
L3

.51 Gestion des orientations | [~ g
=74 Orientations (1)
“ #1: Fixée, Ind. 20.07, Azm. 0.0°

3 Groupes et zones

K sonuier

Nombre total de modules: 0

‘ Fermer |a scéne

Une carte interactive apparait, centrée sur la localisation de votre projet. Vous pouvez
zoomer, dézoomer et déplacer la carte pour ajuster la vue. Notez que la carte est limitée
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aune zone de 11 km x 11 km afin de maintenirla cohérence entre 'emplacement de votre
projet et les données de terrain importées.

e Sélectionner les données topographiques

Pour ce tutoriel, nous allons importer a la fois l'image du terrain et ses données
topographiques. Pour ce faire, cochez la case "Importer également les données de
topographie" en bas de la fenétre de la carte.

[} X

I:I Satellite v
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™
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/ & 4
% 2 21 A7
Wernazomim mise: ©,

b

Figure 2: Zone sélectionnée sur la carte interactive de Bing
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Une fois la zone souhaitée sélectionnée, cliquez sur OK. PVsyst téléchargera l'image et
les données topographiques de la région affichée.

Fichier Créer Sélectionner Editer Transformer Voir Outils Aide

ve [Ma-a v an eee (9D |mEm A alveC |/ .ﬁ‘ .9

Historique Sélection Point de vue Zoom Rendu Modules Mesure Modification Outils Référentiel

v Objets de la scéne | Outis
Zénith < Est citulad ]

{5 Champs PV (0)

() Objets (2)
+[a8] Image du sol
B3 objetsol

¥ o

/32 Orientations (1)
" 21 Fixée, Ind. 20.0°, Azim. 0.0°

> Groupes et zones

..... = 3¢ annuder ” /mhml

Taille case: 50.00 m Géographique - Vue perspective : b X:-648.30, Y: 66.13 m Surf. active : 0.00 m? Nombre total de modules: 0

Figure 3: Image du terrain et objet importé dans la scéne 3D
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e Rogner l'image du terrain (optionnel)

Si l'image importée est trop grande, vous pouvez la rogner pour vous concentrer sur la
zone souhaitée :

o Double-cliguez sur Image du sol dans le panneau Objets de la scéne situé a
droite de la fenétre Construction de la scéne d’ombrage. Cela ouvrira l'outil
d'édition de l'image du sol.

® Construction

Fichier Créer Sélectionner Editer Transformer Voir Outils Aide

| e = P S
e M- |4 2@oat |eaqe 9D |mm |[Favec|/o ls| -0
Historique Sélection Point de vue Zoom Rendu | Modules Mesure Modification Outils Référentiel
Zeénith st Objets de la scéne | Outils
¥ Image dusol -
Image du sol

Echelle de l'image —————————————————

X1 - Origi
X / Ouest 0.000  m
¥/ sud 0.000 m

X2 - 2éme pointsurlaxe — |
¥ [ Ouest -100.00 m
¥ fSud 0.000 m

~Autres paramétres—————————————

Distance X1 -> X2 45592 m
Largeur de limage 100.00 m
' Editer
R
0 | Iy Rogrer

% Pesition du solei

K aonier

[ " Fermerla scéne |

Tl Sud
Taille case: 50.00 m Géographique - Vue perspective o X:-510.83, Y: 295.08 m Surf. active : 0.00 m* Nombre total de modules: 0

Figure 4: Outil d'édition de l'image du sol

o Enbasdupanneau, cliquez sur l'icbne Rogner.

Autres paramétres
Distance ¥1-> %2 435,52 m
Largeur de limage 100.00  m
[ . Editer
]
Opacité < > | @ Afficher/Cacher |

o =

Figure 5: Bouton de rognage dans l'outil d'édition

il
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o Danslafenétre de rognage de l'image du sol, déplacez les c6tés du cadre
pour centrer la sélection sur la zone souhaitée.

€ Rognage de |'image de sol

l x Annuler || /Rogner

Figure 6: Outil de rognage de l'image du sol

o Une fois la zone sélectionnée, cliquez sur Rogner.

o L'image du terrain peut étre masquée par l'objet du terrain. Pour afficher
l'image apres le redimensionnement, supprimez l'objet du terrain (vous
pouvez le restaurer avec Ctrl + Z par la suite).

® Construction de la scéne dombrage - ] X

Fichier Créer Sélectionner Editer Transformer Voir Outils Aide

I B S B, 3 12 = S N IR ; e
5C N | JSPE At |00k (9D |HE (S A (Ve | /O |ME | -9
Historique Sélection Point de vue Zoom Rendu Modules Mesure Modification Outils Référentiel

o Objets de la scéne | Outls
Zénith Est
¥ Objets de la scéne
Nom ¢
& Champs PV (0)
1) Objets (1)
(o8] Image du sol
¥ Orientations
“ -2 Gestion des orientatons | 5 (@)
dord
arg 132 Orientations (1)
#1: Fixée, Ind, 20.0°, Azim. 0.0°
' Ouest
» Groupes et zones
- K aoner H o Fermerla scéne
v, Sud
Taille case: 25.00 m Géographique - Vue perspective & X:60.32, Y:2.87 m Surf. active : 0.00 m? Nombre total de modules: 0
Figure 7: Image du sol dans la scéne 3D
a8 -
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2 Importer une topographie de terrain depuis Google
Earth

e Ouvrez Google Earth Pro (ce logiciel est gratuit, méme s'il porte le nom "Pro")

e Dans le menu "Outils > Options > Navigation", cochez "Ne pas incliner
automatiquement pendant le zoom" (pour rester toujours en vue de dessus a 90°
par rapport au sol)

e Sélectionnez un emplacement en saisissant une adresse ou en vous déplacant avec
la souris

e Cliquez sur l'outil "Ajouter un trajet" et tracez autant de points que possible avec la
souris pour définir la zone souhaitée (l'outil "Polygone" ne générera les données
d'altitude qu'aux coins du polygone, ce qui n'est pas suffisant pour extraire la
topographie de l'aire du polygone)

e Dans l'onglet "Altitude", sélectionnez "Au niveau du sol"

= Google Earth Pro

¥ Recherche

| Annecy-e-Vieu G _
Google Earth - Nouveau Trajet

(LRl as titre Trajed

9An

| Description | Style, Couleur | Affichage | Altitude | Mesures

| Ajouter un lien... | | Ajouter une image Web...| |Ajouter une image locale... |

TE‘ +4
|

U=
x

Lk

Le Christ Rédempteur

Le Grand Canyon

Figure 8 : Google Earth Pro

e Cliquez sur OK pour fermer Uoutil de trajet
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e Selectionnez le trajet créé dans le panneau ‘Lieux’ et enregistrer le lieu au format
KMz

: & Sans titre - Trajet

o Sans titre - Trajet
& Sans titre - Trajet

& Sans titre - Trajet
O - -

T

»

ad
|g| 4

Q@
' Couper
¥ Calgues Copier
¥ |8 Base de do g .
B Annonc HpprimeEr
’ P Frongere eTTeTT

Enregistrer le lieu sous...

P H_oute; il

b =] Batimen Utiliser la vue actuelle
L% Metéo
4
L4

& Afficher le profil de dénivele
¥ Galerie

[3 Plus Propriétés
¥ Relief

Figure 9 : google earth - Save as

e Allez a https://www.gpsvisualizer.com/convert_input

e Selectionnez “Plain text” pour “Output format”
e Selectionnez votre fichier KML depuis “Upload your files here”
e Selectionnez “Semi-colon” pour “Plain text delimiter”

e Selectionnez “Best available source” dans la liste déroulante “Add DEM elevation data”

Output format: I ® plain textI Oarx O Google Earth KML
Upload your files here:  fjja #1 location.kml I
(10 MB max. total size, File #2 | Sélect. fichiers | Aucun fichier choisi

.zip/.gz is supported)
File £3 Aucun fichier choisi

Show more file boxes

Or paste your data here: |;ame, desc, latitude,longitude

Force text data to be this type: | default v
Or provide the URL of a file on the Web: |

Plain text delimiter Plain text output units:

Add estimated fields: [ speed [ | heading [ slope (%] [ distance [ I1vMG [pace
Add DEM elevation dataf | best available source |

Save these settings » Load from saved

Figure 10 : Google earth — Format de sortie
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https://www.gpsvisualizer.com/convert_input

e Cliquez sur “Show advanced parameters”
e Selectionnez “No” pour “Repeat header row in plain-text output”

e Selectionnez “Yes” pour “Output UTM coordinates”

Repeat header row in plain-text output
Output UTM coordinates:||| ves v |}in plain-text output only)
Time offset: : hours
Moving average range for estimated fields (speed, slope, etc.): point(s)

Check this box if your GPX input file uses the wrong unit (km/h) for speed data: ||

Figure 11 : Autres options

e Cliquey sur “Convert”

e Copiezle contenu genéré

The contents of your file are also displayed in this box, if you'd rather cut and paste:

ype; latitude;longitude ;utm_zone;utm easting;utm_northing;altitude (m);name;desc
.364489382;3.870649091;31T;569374.8;4912725.7;1437.1;5ans titre - Trajet;

. 3644729913 3.870588609;31T;565370;4912723.9;1438.4;;
. 364468877;3.870533200;31T;5659365.6;4912723.

. 364460992 3.870499121;31T;565362.9;4912722.5;
-364453448;3.870461807;31T;5658359.9;4912721.6;
-364453612;3.870456815;31T;5658359.6;4912721.6;
-364445267;3.870435609;31T;568357.9;4912728.7;
-364425931;3.878372318;31T;5658352.9;4912718.5;
-364414733;3.878338587;31T;56593508.2;4912717.2;
-364489141;3.878321745;31T;5659348.8;4912716.6;
-364406322;3.878313318;31T;5659348.2;4912716.2;

LTI W e e e
T
W e s M e

SERRRREEEEE

e

C-~ - - R R S RN R,

.

R T L]

L b
Map this data: Leaflet, Google Maps, Google Earth, JPEG map, SVG map, or elevation profile — or go to the map |

Figure 12 : Google Earth — Format de donnée

e Collezle contenu dans Excel

it
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e Dans Excel, cliquez sur “Données>Convertir” et sélectionnez le type “Delimité”

ent automatique (@) [5] )

Fichier  Accueil  Insertion  Mise en page

[BA partir d'un fichier texte/CSV
[® A partir du web

Obtenirdes _
données ~ EEl A partir de Tableau ou d'une Plage [P Connexions existantes

EZ A partir de l'image ~
[ sources récentes

Récupérer et transformer des données
AL - Fe

A B g D E

Formules Révision
’rL [H Requétes et connexions i @ D:]j

R

Requétes et connexions

type;latitude;longitude;utm_zone;utm_ea

F G

Affichage

£ Rechercher

Automate Aide

T YA

I
Donnéesb... Devises (Fr.. Dannéesg.. [z | Z| Trier  Filtrer

Types de données Trier et filtrer

& Avancé

1

2

3 |T:44 364472¢(01:3 870588660;31T;560370:4912723.9:1436. 4;;
4 |T:44 364468¢[77:3 870533200;31T;569365.6:4912723 4;1439 5;;
5 | T:44.364460¢(02:3 870409121:31T;560362 9:4912722 5;1440 13
5 |T:44.36445348:3 870461007;31T;560350.9:4912721 6;1440.7;
7 |T:44 364453¢12:3 870456815;31T;560350.6:4912721.6;1440 85,
5 |T:44.364445:{57:3 870435609;31T;569357 9:4912720 71441 2;;
g |T:44.364425¢31:3 870372310;31T;560352 9:4912718.5;1442 1,
10 | T:44.3644141(33:3 870338567;31T;569350 2:4912717 21442 6;;
11 | T;44 36440014 1:3 870321745;31T;569348 8:4912716.6;1442 8;;
12 | T:44.364406¢[22:3 870313318;31T;569348 2:4912716.2;1443.0;;
13 | T;44.364400¢(21:3 870300633;31T;569347 2:4912715.6;1443.1;;
14 | T;44.3643051(52;3.870275471;31T;560345.2;4912715,1443.5;;
15 | T;44.364302:(75.3.870262024;31T;560344.2,4012714.7,1443.6;;
16 | T;44.364386¢(14;3.870241931;31T;560342.5:4912714,1443.7;
17 | T;44.364384473:3.870221059;31T;560340.8,4012713.7,1443.9;;
12 | T;44.364378¢14;3.870105043;31T;560338.0,4012713.1;1444.0;;
19 | T;44.364370140;3.870166500;31T;560336.5:4012712.1;1444.2;;
20 | T;44.3643654/84;3.870133234;31T;560333.0,4012711.5; 1444 4;;
21 |T;44.3643601(32;3.870005761;31T;560330.9,4012710.9;1444.7;;

type;latitude; pngitude;utm_zone;utm_easting;utm_northing:altitude (m);name;desc
T:44 364489¢(32;3 870649001;31T;560374 8;4912725 7:1437 1:Sans titre - Trajet;

? x

Assistant Conversion - Ftape 1sur 3
L'Assistant Texte a déterminé que vos données sont de type Délimité,

Si ce choix vous convient, choisissez Suivant, sinon choisissez le type de données qui déait le
mieux vos données.

Type de données dorigine

de fichier qui décrit le mieux vos données :
@ Béiimits || - Des caractéres tels que des virgules ou des tabulations séparent
= chaque champ.
Q

Largeur fixe - Les champs sont alignés en colonnes et séparés par des espaces.

Apercu des données sélectionnées :

1 bype;latitude; longitudejutm zone;jutm_easting;utm norshing;altic) &
E 44.364489382;3.870649091;31T;5€9374.8;4912725.7;1437.1;Sans ¢
3

44_.364472991;3 870588665;31T;569370;4512723 .5;1438 4;7
44.3644€8877;3.870533200;31T; 569365 . ;4512723.4; 1439.5; ;

44 3644€0992;3.870499121;31T;5693€2_9;4912722 5;1440 1;; v
< >

Annuler

Terminer

Figure 13 : Données Excel

EE Remp

Suppr

Convertir Pe
Valida

(o] P

e Cliguez sur “Suivant” et sélectionnez “Point-virgule” comme séparateur, puis

cliquez sur “Suivant”

e Supprimez les 4 premieres colonnes (depuis “type” jusque “utm_zone”), et
conservez les colonnes “utm_easting”, “utm_northing” et “altitude”

& D

F&

1

2 369374.8
3 569370
4 369365.6
3 569362.9
& 369359.9
7 369359.6
3 369357.9
9 369352.9
10 369350.2
11 369348.8
12 369348.2
13 369347.2
14 369345.2
15 369344.2
16 569342.5

e Sauvegardez en .CSV et fermez Excel

aPVsysT

utm_easting utm_northin altitude (m)

4912725.7 1437.1
4912723.9 1438.4
49127234 1439.5
4912722.5 1440.1
4912721.6 1440.7
4312721.6 1440.58
4912720.7 1441.2
4912718.5 1442.1
4912717.2 1442.6
4912716.6 1442.8
4912716.2 1443
4912715.6 1443.1

4912715 1443.5
4912714.7 1443.6

4912714 1443.7

Figure 14 : Données
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e Depuisla scene 3D PVsyst, dans le menu “Fichier>Importer>Importer des
données topographques (CSV)”, selectionnez et importez votre fichier CSV

® Construction de la sc2ne d'ombrage

Fichier Créer Sélectionner Editer Transformer Voir Outils  Aide

# MNouvellescéne Ctrl+N b/ z = - .
= ) SRt ty | @© 06,0 PO |IEE | SN
| Lire une scéne Ctrl+0 :
Point de vue Zoom Rendu Modules Mesure
Lire un batiment f
| Lire des objets Zénith
= |mporter > Importer une scéne 30 (305, DAE, PVC)
L Exporter la scéne (.5HD) Ctrl+5 | wer| Importer un fichier Helios3D (H2P)
Exporter les objets sélectionnés ((SHO) st Importer des données tepographiques (CSV, TIF)
& Sauver cette vue de la scéne »| @ Importer une image de sol
@ Imprimer Cirl+P & Télécharger une image satellite de sol et/eu des données topographiques
® Annuler Ctrl+ 0
" FEermerla scéne Ctrl+W

Figure 15 : PVsyst — Importer des données topographiques

e Latopographie devrait étre correctement importée. Veuillez noter que si vous étes
dans ’hémisphéere Nord il vous faudra appliquer une rotation de 180° autour de
Uorigine de la scene pour gu’elle soit positionnée correctement.
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Shading scene construction

File Create Select Edit View Toocls Help

5c k"i“vw-.”'.uxﬁt.v @ @ § Q!

History Selection Pomt of view Zoom

@ O

Render

Meaz

Zenith East

West

Figure 16 : sol PVsyst

3 Convertir un fichier Autocad .DWG vers .DAE depuis
sketchup

e Ouvrez Sketchup Pro

e Cliquez sur “File>Import” et sélectionnez un fichier Autocad .DWG
e Cliquez sur “File>Export>3D model”

e Selectionnez “Collada (*.DAE)” et sauvegardez votre fichier.

e Depuis la scene 3D PVsyst, dans le menu “Fichier>Importer>Importer une scene
3D (3DS, DAE,PVC)”, selectionnez et importez votre fichier

il
‘ : PVSYS.I. PVsyst SA - Importer une Topographie Page 13
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4 Import d’un sol depuis sketchup

e Ouvrez Sketchup Pro
e Depuis le menu Ficher, cliquez sur “Ajouter un emplacement".

e Dans lafenétre “Ajouter un emplacement”, tapez ’adresse ou bien positionnez
la localisation désirée de votre terrain, puis cliquez sur “Continue”

e Cliquez sur le bouton "Continue", et une vue aérienne de 'emplacement
apparait dans la fenétre.

e Danslazone “Import type” sélectionnez “3D Mesh”

e Déplacez les coins de la zone sélectionnée afin d’affiner ’emplacement.

e Cliquez sur le bouton “Import” et le sol de votre emplacement est importé dans
votre modele.

9 Ajouter un emplacement X

Type de carte

. -—
En savoir plus Plan des rues

Importation de la

région
Résolution @
Fournisseur d'images @
4 [Animation Position géographique b Y

Classements - DigitalGlobe

Composants 3 e . : < - 3 b )

Fiay ) Cemodéle nest pas géopositionné o @ting

Oddt £n gé e modéle, vous définissez e

prédis de ce modéle sur terre, Les études solaires seront plus ’ - | (I Limites des carreaux

— prédises et vous aurez accés & un répertoire de données du -

Statistiques site trés complet comprenant des images satelite etle terrain. |

Texte L

Unités

Effacer [emplacement Ajouter un emplacement...

Paramétres avancés

Définir un emplacement manuel... Droit d'utilisation du contenu

\ Cliquez ou faites glisser pour sélectionner des objets. Maj = Ajouter/Soustraire. Ctrl = Ajouter. Maj + Ctrl = Soustraire.

Figure 17 : Sketchup Import ground

e Cliguez droit sur le terrain et sélectionnez d’abord “Unlock” puis “Explode”
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Figure 18 : Ground under Sketchup

e Depuis le menu “File>Export>3D model”, exportez le terrain au format fichier
COLLADA “.DAE”

e Dans lascene 3D PVsyst, depuis le menu “Fichier>Importer>Importer une scene
3D (3DS, DAE,PVC)”, sélectionnez et importez votre fichier.

e Cliquez sur “OK” dans la fenétre d’import: votre object sol est maintenant
importé

e Faites un clique droit dessus et sélectionnez “Transformer en objet sol”

® Construction de la scéne d'ombrage

Fichier Créer Sélectionner Editer Transformer Voir Outils Aide

) Y (2t 42 Py .o 7 i
¢ IRN-QD- (Y RUPS S Qe R |90 (EHE SN (RSP 7E AT )
Historique Sélection Point de vue Zoom Rendu Meodules Mesure Modification Outils Référentiel
Objets de la scéne | Qutils

Zénith
| ¥ objets dela scene
g £5p o ‘
-~/ Champs PV (0)
[=-{) Objets (1)
-5 Object 1 v
e =&
ol — -
% =
il >
™ 4, Modifier I'objet Ctrl+M
% e & Déplacer Ctl+B [ndesorientatons | 1 G
L\ > 5 (* Pivoter Ctrl+R  entations (1)
Fixée, Ind. 20.0%, Azim, 0.0°
e > [%] Transformer en faces PV
S g [€] Transformer en objets
- Convert fixed tables to trackers
o e T -
<7 [%] Transformer les tables PV sélectionnées en rangées de tables
< a e [ Transformer en objet sol
[] Copier
X Supprimer l'cbjet rem—
" [ Centrer sur I'objet sélectionné Ctrl+F
@uest Q Position de I'observateur ‘ Annuler | /Fermar\asoéne
Taille case: 5.00 m Géographique - Vue perspective 4 X:-11.63, Y: 642 m Surf. active : 0.00 mz Nombre total de modules: 0

Figure 19 : PVsyst — Transformer en objet sol
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